Monday 27th August 2018

FileLocker Filelocker Unavailable

The FileLocker secure file exchange service (https://files.umflint.edu) is currently unavailable. ITS is currently investigating this and will post updates when they become available.

[UPDATE] Technicians have identified the issue and are actively working to resolve the problem. We do not currently have an ETR at this time.

[UPDATE] The service has been completely restored. If you have any more trouble with this system please contact the ITS Helpdesk at (810)762-3123. We apologize for any inconvenience and thank you for your patience.