Tuesday 7th August 2018

All Email Outlook Outage

A problem has been reported that email is not being sent or received currently. ITS System Administrators are currently looking into the problem and we will update this message when we have more information.

[Update] Technicians have identified the problem and only a small number of users are currently affected. We appreciate your patience while we work to restore full functionality.

[Update] Full functionality of email has been restored. If you experience any more trouble with this system please contact the ITS Helpdesk at (810)762-3123 opt. 1 or ITS-Helpdesk@umflint.edu.